2010-2014 ACS 5-year PUMS csv file size?

Hi all,

Has anyone downloaded the 2010-2014 ACS 5-year PUMS csv files from the Census Bureau successfully?  I'm trying to download the population and housing files for the US but seem to be getting something funky.  The first population file ss14pusa.csv is listed as 807 petabytes -- that's roughly 825,000 TERABYTES! The other files, pusb/pubc/pusd are normal sized, around 600,000 KB.  I looked at the SAS files, and they are normal sized, unfortunately I don't have access to Stat Transfer.

If anyone has any info about this file or recommendation of a person to contact within the Census Bureau I'd appreciate it!



  • Hi Nicole,

    I was able to successfully download the 2010-2014 ACS 5-year PUMS file both as SAS and as CSV using their new links on Factfinder (new interface than their old FTP site):


    exact link for CSV files:

    If there's a particular state or group of states you're interested in, you can download just those states' files, since it will be much smaller in size than the records for the whole US.

    The United States Population Records file CSV zip file ("csv_pus.zip") was 2.3 GB, it took about 5 minutes to download and unzip. Then you see the ss14pusa, ss14usb, ss14usc, and ss14usd files, as well as the readme pdf. The ss14pusa.csv is 4.25 GB, and the others are around 3.5 GB. I opened it with Ultra Edit, got the "large file" warning, and it opened at normal speed (less than a second). From there you should be able to read it into Stata or SPSS, or whatever you plan to use.

    I tried opening it in Excel (2013 version), to see what would happen. It took a good few minutes, then got a message that there wasn't enough memory. I also tried Notepad, and got the same message. I successfully opened it in Tableau, it took much longer than usual, but it did work eventually.

    I hope this helps! If you're still getting crazy file sizes from FactFinder, let us know!
  • In reply to Diana Lavery:

    Thanks, Diana. I heard back from the Census Bureau, and I'm posting their response here in case others run into the same issue:

    "This is actually a pretty common bug--for some reason, if you are using Windows and right-click on the file and choose Windows' native "extract" option, it sometimes says that the file is extremely large. If you use a extraction tool like WinZip instead, it will unzip properly."